Mise à jour perso de l’extension Firefox GOUP

Bonne année à tous et à toutes.

La fin de l'année passée a été fournie en mises-à-jour de quelques de mes logiciels employés:

Comme j'ai pas mal de boulot, la mise-à-jour de WordPress attendra un petit peu.

Par contre, comme j'emploie tout le temps Firefox et que sa mise-à-jour a changé quelque peu la gestion d'extension, j'ai été un peu embêté de voir qu'une de mes extension préférée ne fonctionnait plus: l'extension GOUP.

GoUp Extension Icon

Cette extension permet, à l'instar du bouton "navigate to parent directory" de la barre d'outils Google pour MS Internet Explorer, de remonter automatiquement d'un niveau sur un site web lorsque l'on clique sur son icône. Très pratique lors d'erreurs 404 et/ou pour visiter les blogs.

Google Toolbar

J'ai donc effectué une petite recherche sur le web pour voir comment on pourrait modifier une extension Firefox: je suis tombé sur ce site explicatif: Roachfiend.com.

Rien de plus simple à partir de ce lien.

Le fichier xpi que l'on peut télécharger est en peut être ouvert avec avec Winzip ou Winrar. C'est une archive contenant un fichier install.rdf, contenant lui-même les informations concerant l'installation de l'extension, et un folder contenant lui meme une archive .jar, qui contient toutes les informations concernant le fonctionnement de cette extension.

Inside the .xpi

Le problème se situait dans l'id de l'extension:

Clav n'avait pas spécifié un guid valide d'où l'erreur affichée lors de l'installation de l'extension:

Invalid GUID error message

Toujours en suivant le site Roachfiend.com, j'ai trouvé un générateur de guid et j'ai corrigé l'extension erronnée.

Après avoir archivé les fichiers modifiés, j'ai enfin pu installer cette extension que je mets à votre disposition !

Cet article vous a plu? Réagissez :)

Comments

3 commentaires à “Mise à jour perso de l’extension Firefox GOUP”

  1. Gatellier.be le 27/10/2006 à 11h15.

    Ré-activer les anciennes extensions de Firefox grâce à about:config...

    Avec la sortie de la version 2.0 de Firefox, beaucoup d’extensions ne sont plus compatibles. Leur développeurs n’ayant pas encore mis à jour les fichiers d’installations.
    On a vu ici et là des versions non-officielles de mises à j...

  2. Jamal le 17/11/2006 à 00h06.

    Help me please...
    I just installed Firefox 2.0, and all of a sudden, my username/password isn't being inserted in the signon window (it always was before). I tried the usual suspects--I did not mistakenly tell FF not to remember the password for this site; and I also tried the remember password bookmarklet, but all to no avail--FF will not ask me to remember this password. What do I need to do to get around this?

  3. Marin le 17/11/2006 à 12h18.

    Hello Jamal,
    You might try to uninstall FF *prior* the upgrade to FF2. (all settings are kept)
    I encountered some problems too on one of my computers.
    Let me know if it works.

Laissez un commentaire